A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed
Topic Rating: 0 Topic Rating: 0 (0 votes) 
sp_TopicIcon
Onkyo TX-RZ3100 HDMI issues driving me crazy!
Avatar
LS
Member
Members
Forum Posts: 8
Member Since:
November 6, 2017
sp_UserOfflineSmall Offline
1
November 6, 2017 - 9:15 am
sp_Permalink sp_Print
0

I have a Onkyo TX-RZ3100 and everything worked well the first 2-3 months and then it started having serious HDMI board issues. I now have to reset the receiver so that it works and that doesn’t last long. Has anyone else had problems with this model?

Avatar
Andy
Member
Members
Forum Posts: 13
Member Since:
November 8, 2017
sp_UserOfflineSmall Offline
2
November 8, 2017 - 12:10 pm
sp_Permalink sp_Print
0

Unfortunately you’re not alone, LS. I have had problems with this particular model but I had them ever since I got it. Thing is I don’t use the HDMI-CEC features so that is not a very big deal for me but I can understand it is for you. Onkyo makes great receivers but they (still) haven’t fixed these issues.

Avatar
LS
Member
Members
Forum Posts: 8
Member Since:
November 6, 2017
sp_UserOfflineSmall Offline
3
November 10, 2017 - 9:24 am
sp_Permalink sp_Print
0

So, you mean to say that there are other Onkyo models that have this problem?

Avatar
Andy
Member
Members
Forum Posts: 13
Member Since:
November 8, 2017
sp_UserOfflineSmall Offline
4
November 10, 2017 - 10:40 am
sp_Permalink sp_Print
0

Yeah, Onkyo have had some serious problems with this in the past on some of its models. Some people have stopped buying this brand altogether because the fixes are slow to arrive or aren’t arriving at all. 

Avatar
zamdo
Member
Members
Forum Posts: 23
Member Since:
November 7, 2017
sp_UserOfflineSmall Offline
5
November 13, 2017 - 2:44 pm
sp_Permalink sp_Print
0

The sound quality of the Onkyo is very good but they do ask a high price considering they have unsolved problems like this one you’ve encountered. So, are you here to find a solution to your problem or just to vent, LS? Have you contacted them and asked for a solution?

Avatar
LS
Member
Members
Forum Posts: 8
Member Since:
November 6, 2017
sp_UserOfflineSmall Offline
6
November 14, 2017 - 11:11 am
sp_Permalink sp_Print
0

zamdo said
The sound quality of the Onkyo is very good but they do ask a high price considering they have unsolved problems like this one you’ve encountered. So, are you here to find a solution to your problem or just to vent, LS? Have you contacted them and asked for a solution?  

Mostly to vent I guess. I contacted them and they will fix it (sent it in service right now). I’m disappointed that this happened to a high end device like this and so quickly after I got it.

Avatar
Payton
Member
Members
Forum Posts: 13
Member Since:
November 9, 2017
sp_UserOfflineSmall Offline
7
November 15, 2017 - 1:41 pm
sp_Permalink sp_Print
0

Also had issues with this model plus it didn’t have a programmable remote and I hated that. It just seemed like they got cheap and didn’t make one or something. Anyway, not buying from Onkyo ever again.

Avatar
Noah
Member
Members
Forum Posts: 4
Member Since:
November 7, 2017
sp_UserOfflineSmall Offline
8
November 20, 2017 - 1:32 pm
sp_Permalink sp_Print
0

Unfortunately, there are a decent amount of Onkyo models that have all sorts of issues. Not saying Onkyo is a bad brand but it could be a lot better. I wouldn’t get anything from them at the moment because they aren’t reliable.

Avatar
chris
New Member
Members
Forum Posts: 1
Member Since:
August 18, 2018
sp_UserOfflineSmall Offline
9
August 18, 2018 - 10:30 pm
sp_Permalink sp_Print
0

I’m having an issue myself. Not sure what it is though. Initially I had a 50’ fiber  hdmi running from the 3100 to the QLED. The cable worked if I put it directly into the tv. It didn’t work once I sent it through the receiver. So I bought HD Base T to run cat 5 the distance. It worked. But every now and then I suddenly get a snow screen. My confusion comes from wether it is the receiver or the HD Base T. To further the confusion, when the snow screen comes on, I can unplug the power of the HD Base T and plug it back in and the snow screen goes away. The same thing happens when I turn the receiver off and back on. So I can’t tell what is causing the problem. I can be watching tv for a long period of time and it just happens out of nowhere. I called Onkyo and they didn’t really know either. They wanted me to take it to a service center. But then I’ll be without the receiver for 2 weeks. Any advice would be helpful. Thanks.

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 29

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

zamdo: 23

cptahab: 15

AB: 14

Payton: 13

Andy: 13

Jack: 10

Robert: 9

LS: 8

Liberty0: 7

Jo77: 7

Newest Members:

jaycee

caplab01

chris

Matt

gr2

Ana

trevorjames

jj

jamiews

Laura

Forum Stats:

Groups: 2

Forums: 21

Topics: 40

Posts: 212

 

Member Stats:

Guest Posters: 0

Members: 52

Moderators: 0

Admins: 2

Administrators: wpengine, Onuora Amobi